Need a little help

Location
USA
Just finished installing a factory B limited pipe on my 2004 superjet. Starts and idles fine but won’t review up past 1/3 throttle. I can get up on plane but nothing past that. Compression is even front and back. Ski ran fine before the mods. Where should I start to troubleshoot?

Here are the other mods I did to the ski:
MSD ignition
Carbon tech reeds
ADA girdled head with 35cc domes
After market flame arrestors

Carbs adjusted per FP instructions
135 main jet
Stock 70 pilot jet
High speed screw 1.5 turns out
Low speed screw 1.25 turns out
Stock 95 gram spring
 

Attachments

  • 8F19EAC1-D3E4-4506-B287-1BF5E48F6EF4.jpeg
    8F19EAC1-D3E4-4506-B287-1BF5E48F6EF4.jpeg
    208.1 KB · Views: 36
New MSD Enhancers come preset from the Factory at 8000rpm.

No guarantees though....Could have been dialed all the way down to 5500 rpm.

Set the MSD Enhancer to the max RPM of 9000 rpm for testing purposes. You can readjust down to 8000 rpm later after it runs right.

Go thru the E-Box again and ensure all Bullet Connectors are mated tight. Ensure ALL the Grounds are screwed down tight.

Make sure the Pink Wire is capped and not grounding out, Same for any loose leftover Wires....

How's the Battery? The MSD Enhancer runs off the Battery for Spark Energy, not the Magneto, so the Battery needs to be strong and fully charged.

Make sure the Battery connections are clean and tight. Especially the Negative/Ground Wire.
 
Last edited:
Also make sure the Choke Butterfly is not blocking the Air Flow. Are the Throttle Butterflies synchronized and fully opening at Full Throttle?

And that Bubble Gum 1/4" Hose used as a Pulse Line can be a Leaker. The Engine gets hot and that Hose will go soft and so will the Plastic Zip Tie holding it to the Pulse Nipple on the Crankcase. Can easily split too. Just to be sure it won't leak, split or collapse, use an OEM type Hose with a Stainless Clamp at the Crankcase End.

Bubble Gum Hose is pretty but deadly o_O
 
Try a 75 pilot jet too. Might be lean off the bottom and 1/3 throttle is in the pilot jet/popoff range. I see you changed the popoff with the 95g spring, have you checked your popoff with a gauge to verify correct popoff pressure on both carbs, By chance, have you also tried the stock cdi to verify the msd is good? What did you set your screws on the pipe to? Also, hard to tell from the pic, but do you have a tee from the headpipe outlet to the stinger with one end going to a pisser? Otherwise you have way too much water going into the waterbox and that will definitely not allow the engine to Rev out. Also recommended to run either a flow control valve or use a 1/4 od barbed fitting with a piece of 1/4 fuel line over it. The 3/8 cooling line will slip right over it. Run a tap through the inlet side and a mikuni main jet will screw right in. Tap size is m5x.07 jet would be in the 140-150 range for the stinger. I like the flow control valve because it's adjustable by loosening or tightening the valve.
 
Last edited:
Location
USA
Try a 75 pilot jet too. Might be lean off the bottom and 1/3 throttle is in the pilot jet/popoff range. I see you changed the popoff with the 95g spring, have you checked your popoff with a gauge to verify correct popoff pressure on both carbs, By chance, have you also tried the stock cdi to verify the msd is good? What did you set your screws on the pipe to? Also, hard to tell from the pic, but do you have a tee from the headpipe outlet to the stinger with one end going to a pisser? Otherwise you have way too much water going into the waterbox and that will definitely not allow the engine to Rev out. Also recommended to run either a flow control valve or use a 1/4 od barbed fitting with a piece of 1/4 fuel line over it. The 3/8 cooling line will slip right over it. Run a tap through the inlet side and a mikuni main jet will screw right in. Tap size is m5x.07 jet would be in the 140-150 range for the stinger. I like the flow control valve because it's adjustable by loosening or tightening the valve.
I have a tee installed in the cooling line from the headpipe. One line goes to the pisser and the other to the stinger. I do not have any flow control valve or restriction. Am I flooding the water box? Sounds like a good place to start
 
Make you don't have any exhaust leaks. A small leak will stave the engine and not rev.
Easy test, leave it on the trailer with hood off and see if it will rev out on wot.
 
Location
USA
New MSD Enhancers come preset from the Factory at 8000rpm.

No guarantees though....Could have been dialed all the way down to 5500 rpm.

Set the MSD Enhancer to the max RPM of 9000 rpm for testing purposes. You can readjust down to 8000 rpm later after it runs right.

Go thru the E-Box again and ensure all Bullet Connectors are mated tight. Ensure ALL the Grounds are screwed down tight.

Make sure the Pink Wire is capped and not grounding out, Same for any loose leftover Wires....

How's the Battery? The MSD Enhancer runs off the Battery for Spark Energy, not the Magneto, so the Battery needs to be strong and fully charged.

Make sure the Battery connections are clean and tight. Especially the Negative/Ground Wire.
Turned up the rev limiter all the way and no change. All connections are good. Battery is strong and fully charged.
 
Wont rev up as in it goes rich (bogs)? or does it act like hitting limiter ( Ba Ba Ba Ba Ba ) ? you didnt say msd was new so if it acts like its on limiter i would say its gone bad. ive had a few do that. If not you better double check your carb work.
 
Location
USA
Wont rev up as in it goes rich (bogs)? or does it act like hitting limiter ( Ba Ba Ba Ba Ba ) ? you didnt say msd was new so if it acts like its on limiter i would say its gone bad. ive had a few do that. If not you better double check your carb work.
Seems to bog when I try to accelerate past 1/3 throttle. It gets me up on plane but won’t rev past that. The MSD is new. I still have the factory ignition. I rebuilt the carbs and replaced all the lines. Just ordered a pop off gauge, going to check that next
 
Location
USA
Try a 75 pilot jet too. Might be lean off the bottom and 1/3 throttle is in the pilot jet/popoff range. I see you changed the popoff with the 95g spring, have you checked your popoff with a gauge to verify correct popoff pressure on both carbs, By chance, have you also tried the stock cdi to verify the msd is good? What did you set your screws on the pipe to? Also, hard to tell from the pic, but do you have a tee from the headpipe outlet to the stinger with one end going to a pisser? Otherwise you have way too much water going into the waterbox and that will definitely not allow the engine to Rev out. Also recommended to run either a flow control valve or use a 1/4 od barbed fitting with a piece of 1/4 fuel line over it. The 3/8 cooling line will slip right over it. Run a tap through the inlet side and a mikuni main jet will screw right in. Tap size is m5x.07 jet would be in the 140-150 range for the stinger. I like the flow control valve because it's adjustable by loosening or tightening the valve.
If my water box is flooded is there a trick to get the water out without removing the box?
 
It should clear out when it's out of the water. If it doesn't hit the limiter out of the water, I think you have other issues. It should clear out once you get up on plane even with no restrictor to the stinger.
 
I'm wondering if the Pink Wire is connected to the Enhancer....o_O

If it is, then that would enable the Holeshot Feature which will hold the RPMs to 3200-3600 :D

Disconnect the Pink Wire and Cap it! :p
 
Top Bottom