Jetting and pop off for 61x w/SBN 44

So I'm trying to help a buddy get his blaster together. Previously it was a 61x with r&d head, factory pipe, water box, SBN 44 single carb.

Now it has an ADA girdled head, and ported cylinders.

When it was first started up it ran alright until it hit the high speed jet and it fell on its face. But now, it's all sorts of messed up.

Replaced about everything in the ebox and the stator.

Looking into the carb you can see the fuel dripping into the carb at idle. I closed the screws all the way, and same thing. So I'm thinking pop off is too low?

Anyone running a similar setup? Also a good SBN 44 carb was taken off another 61x and it did the same thing. Only difference in skis was this one has ported cylinders.
 

CRJ

Hibernating
Location
Toronto
so you changed the head and ported it and nothing else changed? Maybe the pop off spring broke? you'll need to jet up a bit for the new port work. i believe stock 44 61x is 135m 120p 1.5ns. you'll really just have to see whats in there already and go from there. My 61x w/ single 46 and coffman pipe likes to be around 140m 125p 2.0n/s 95g spring.
 
I was thinking there was a problem with the spring. The darn thing runs with both screws closed. Haha. Can still see fuel dripping in too

Also we didn't port it we bought it used and already ported
 

Quinc

Buy a Superjet
Site Supporter
Location
California
The needle wears out and leaks, or your pop off is too low. I would try 130L 155H pop off 21psi. (assuming a/m flame arrestor)
 

CRJ

Hibernating
Location
Toronto
I was thinking there was a problem with the spring. The darn thing runs with both screws closed. Haha. Can still see fuel dripping in too

Also we didn't port it we bought it used and already ported

yea go over everything.
The needle wears out and leaks, or your pop off is too low. I would try 130L 155H pop off 21psi. (assuming a/m flame arrestor)
I ran 150m 125p 95g spring 2.0 n/s on my 763 with 84.5 mil pistons, so that may be a bit rich.
 

Roseand

Ready to RIP
Site Supporter
Location
Wisconsin
Jetmaniac and holeshot have been recommending around 125 pilot, 147.5-150 main with a 95 gram spring. Basically just a little bit more fuel than a B pipe jet setup on a 44mm carb.
 
What's your riding temp and elevation? People can suggest all kinds of wrong jetting


We are sea level, mostly 60-75deg water or whatever the Atlantic is depending on the time of the year.

I took carb apart, it has 120p 150m looks like a 1.8 seat not sure on the needle, or spring.


 

CRJ

Hibernating
Location
Toronto
What's your riding temp and elevation? People can suggest all kinds of wrong jetting
hes in Virginia which is essentially sea level.thats a 95g dul silver spring. you should be on point for jetting. clean it, make sure its all clean. i cant tell if the needle is still good or not.
 

VXSXH20

Sionis Industries
Location
Mid-Atlantic
if it ran with what you have in there prior to the porting and head change, Leave what you have in there for testing purposes. The needle and seat are leaking If you have fuel dripping into the carb throat after you shut it off, or while stumbling/running this is a dead giveaway. replace the needle and seat. start over with your mixture screws. don't make a lot of changes or else you will just be chasing more gremlins. take a breath and take your time.
 
So, it's something electrical, we swapped the entire electrics off of a running blaster (and carb). Ran perfect didn't leak fuel into cylinders. Put carb back on and same thing ran great. Swapped all the electrics back over and wam problem returns. Bran new 62t stator flywheel, cdi out of my 2014 SJ, and a good coil.

Something weird is going on.
 
Yea dont go too nuts on changing things like crazy.

Easy does it.

Don't change stuff to fast or the gremlins will smell it and hastle you for a while.
 
Haha, so unplugging the white with red stripe wire from the stator (pulsar coil) it runs good, revs up. Plug it in and it's like timing is off and it just dumps fuel and the cdi won't let it rev up.
 
Top Bottom