Recent content by Zippo

  1. Z

    750 Sxi Pro bringing back to life - frozen bearing?

    I’d like to keep the pipe for now but will keep you in mind
  2. Z

    750 Sxi Pro bringing back to life - frozen bearing?

    It’s the prop binding on the pump. I can hear it hitting the wear ring in one place as it rotates. I could pull the pump and send it in for a new wear ring but hoping to not have to do that and brap it without chewing the prop up.
  3. Z

    750 Sxi Pro bringing back to life - frozen bearing?

    Ended up pulling the engine. It engine spins fine. The drive shaft took a bit pressure but started freed up. I can feel it binding in one part on the the rotation on the wear ring. Now debating pulling the pump off and sending it out for a new wear ring or just braking it. To answer my first...
  4. Z

    750 Sxi Pro bringing back to life - frozen bearing?

    Took the rest of the exhaust off to get a better look at some of the connections. Noticed the throttle cable looks broken to a 90 degree bend. I don’t recall it being like this but can’t remember. The throttle has too much friction on it for sure. May need to get new cables.
  5. Z

    750 Sxi Pro bringing back to life - frozen bearing?

    Hey guys, Have this 02 750 sxi pro. Haven’t run it for a few years. It got some rainwater it for a few months while sitting. Now it’s time to start wrenching and get back to riding. Seems like I got a lot of work to do. Old battery was toast so Put in a new battery still nothing (no click)...
Top Bottom