MSD total loss vs TS2 Twin spark ignition.

Joined
Aug 29, 2014
Likes
10
Also living in an area away where people that actually tune these Powervalve type motors is hard but sometimes its best to take to someone to get everything setup and then you have minor changes when you get back home.
 
Joined
Feb 23, 2015
Likes
73
Location
Chicago
I have MSD on both my big motors no issues and technically if you read way into MSD it fires up to 20 times below 3000 rpm depending on how much time it has to continue to spark before it need to spark agian at proper time. But truth be told on hot spark is much better then many weak ones. So if you are running a single channel it 3000 is actually 1500 rpm before its mono spark per rev.

If there is anything I have learned about Jetskies and reliability its to by new parts and have them setup properly by someone if you dont know how. Listening to others and piecing things together makes for nightmares. No one can send you something and say its setup for your motor because your jetting, altitude and temperature will change things even if parts are all the same.

For example my ski in the winter the jetting is great but the summer its almost to rich. And if i play with the timing maybe take some out since it hotter it might change everything.

Thats what my understanding was. Everything was new but just not set up. I had done a ton of research and I believe I get it but need to go threw the wiring and make sure everything is perfect.
 
Joined
Feb 23, 2015
Likes
73
Location
Chicago
Yes it sucks that nobody works on this stuff around my area! Does anyone know anyone that lives the Chicagoland area that will tune it? I will pay to have it done right! Im sick of taking it out and not being able to ride it.

Thanks
 
Joined
Aug 29, 2014
Likes
10
I have an RRP E Box so its a pain in the butt to make any changes! Do you have a picture of your set up? I let someone else try to dial it in and they did a poopty job so went threw the wires and soldered them together and I noticed the one stud for 2-3 small ground wires was loose. When you said you ran 3 ground wires what gauge wire did you run?

2 weeks ago it ran good but not the best the guy I let work on it smashed a wire in-between the lexzan glass and box and it sparked and the electronics went dead. Now it slowly cranks and kills the battery in less than 30-60 seconds. I even pulled a plug to make sure there was nothing mechanical wrong and check spark and the spark was hit or miss. I been messing with this thing for so long I just want to ride! I don't know if there is a special set up that I can run but I have it 30deg advanced I believe and switches are right I believe. I wonder if a coil is bad or the MSD box is bad? Im lost.

Any help would be much appreciated!

Thanks Mickey
Battery going bad that quickly has to be some kind of short if its the MSD should unplug it and measure the load between its power and the battery with a multi meter measuring the amp draw.
 
Joined
Apr 8, 2009
Likes
300
Location
denmark
Here is a pic of mine i run 2 25mm2 Ground wires and 1 4mm2 from stator, i use tinded marine grade cabels i dont solder anything it tens too break Racing guys dont doo ither. I use clamb ons with heat schring and then heat schring againg with glue in it. The rrp enclosure is not the Best couple off guys Here also hade issues with them IMG_0290.JPG
 
Top Bottom