Ignition troubles, aftermarket solutions?

Joined
Aug 15, 2018
Likes
11
Location
PA
#1
I’ve had a rash of old stock igniters on my SXI Pros go bad.

Found an NOS MSD Enhancer to replace one with, but now I’m in need of another.

I really don’t see the need to put a $700 Advent in a 90’s SXI Pro but most stock ones online seem “unavailable” or “out of stock”.

Jet Ski Solutions recommended stock and said that the Chinese/eBay/SBT junk ignitions are all a toss up and will most likely leave me high and dry on a Saturday afternoon sooner than later.

So multiple questions:

1. Are the MSD 4251 enhancer igniters no longer available?

2. Is the stock Kawi 2119-3738 igniter still available?

3. Has anyone had any experience with any stock aftermarket igniters that they can recommend? Such as Arieltek’s from Jet Ski Plus?

https://www.jetskiplus.com/kawasaki-750-sxi-sxr800-sxi-pro-xir-sxr-800-cdi-ignitor-21119-3738-new

4. The next most affordable upgrade seems to be the “Venom” with supposedly a recurve and advance with a 9k rev limit. This is half the price of a MSD or Stock and double the price of the Chinese junk......but is the quality any better? Anyone have any first hand experience with the Venom?

https://www.jetskiplus.com/kawasaki...nce-cdi-igniter-21119-3764-higher-rev-limiter

5. Any other options? I hear talk of other ignitions (cdi-10r? HSU?) but they must be a thing of the past as I cannot source them.


Any help or input would be appreciated!
 

Jr.

Standing Tall
Staff member
Joined
Jan 13, 2006
Likes
932
Location
Hot-Lanta
#5
I’ve had a rash of old stock igniters on my SXI Pros go bad.

Found an NOS MSD Enhancer to replace one with, but now I’m in need of another.

I really don’t see the need to put a $700 Advent in a 90’s SXI Pro but most stock ones online seem “unavailable” or “out of stock”.

Jet Ski Solutions recommended stock and said that the Chinese/eBay/SBT junk ignitions are all a toss up and will most likely leave me high and dry on a Saturday afternoon sooner than later.

So multiple questions:

1. Are the MSD 4251 enhancer igniters no longer available?

2. Is the stock Kawi 2119-3738 igniter still available?

3. Has anyone had any experience with any stock aftermarket igniters that they can recommend? Such as Arieltek’s from Jet Ski Plus?

https://www.jetskiplus.com/kawasaki-750-sxi-sxr800-sxi-pro-xir-sxr-800-cdi-ignitor-21119-3738-new

4. The next most affordable upgrade seems to be the “Venom” with supposedly a recurve and advance with a 9k rev limit. This is half the price of a MSD or Stock and double the price of the Chinese junk......but is the quality any better? Anyone have any first hand experience with the Venom?

https://www.jetskiplus.com/kawasaki...nce-cdi-igniter-21119-3764-higher-rev-limiter

5. Any other options? I hear talk of other ignitions (cdi-10r? HSU?) but they must be a thing of the past as I cannot source them.


Any help or input would be appreciated!

I have done a lot of work on the K750-800 motors over the years.
The CDI’s are a very good reliable part. The stators have always been the part that fails? If im reading your issues correctly, you still have the origional stator? What about coil?
Regulator/rectifier? Im thinking you need to look at the component that is giving you this reoccuring issue? Those parts would be the coil and rectifier?? Will be difficult to simulate the condition to find on a meter? But the parts are cheap enough to just replace. So When you replace this CDI, do so with a oem or msd enhancer. And an oem coil with oem boots, and an oem rectifier.
Let me know how you make out?

Ski ya, Paul
 
Joined
Aug 15, 2018
Likes
11
Location
PA
#6
I have several skis and plenty of spare parts to swap out, it is definitely the igniter. I may have been dramatic, by “ rash”.... by that I mean one failed and I bought a used none running ski with a bad igniter. I swapped out coils, ohm’d the coils, and tested the stator. Swapped the igniter with the MSD and it ran so I can’t be on the wrong track.

The ski would shut down while riding occasionally, just quit after about 40mins. The ski would start up and run again, this went on for several months sporadically. Finally quit and was able to limp home at an idle. Once home would not run for more than a second or two but would fire up quickly each time you tried and subsequently die. The plugs would fire for like two seconds and never again on initial start up, but stop the start cycle and attempt another start and it would fire again for just two seconds...from what I’ve researched that is a typical bad igniter.

But yes regardless probably good to replace stuff while I’m in the box. I did replace the coil of the one with the MSD with an OEM coil as well, but I did not replace the rectifier with new but a used one I had on hand. Hopefully the problem doesn't duplicate itself.
 
Last edited:

Jr.

Standing Tall
Staff member
Joined
Jan 13, 2006
Likes
932
Location
Hot-Lanta
#8
The trigger on the stators are known to go bad often. Its easily confused as a igniter going bad.
Rarely, if ever does it hurt the igniter. In many applications, the trigger is ground down to allow clearance for a timing advance plate. When the plastic housing is ground too thin, this is where they short out.
You stated above, that you changed CDI, with same stator, and it ran? If this is correct? Then the issue is CDI or Coil? when a trigger fails, it normally sparks once, then nothing.
 
Joined
Sep 22, 2010
Likes
22
Location
Lewisville
#10
What you describe is Classic Stator Fail on the 750. Even after changing CDI's and leaving the Stator alone. (I lived this Nightmare) JSS Tests them by Heating them up to operating temp putting on a meter then hitting it with a Leather mallet. If the Readings go Crazy its Bad stator, and will fail at temperature.
 
Joined
Aug 15, 2018
Likes
11
Location
PA
#11
Hey thanks. Yeah, since this post I purchased a complete SXR ebox and two more MSD enhancers! I figured I’m covered now in the future if anything fails I’ll have a complete box to just swap out. I was also planning on sending at least one Stator to JSS for overhaul. But now you have me thinking....

So here was the final situation with the ski. Dead cold ski, hadn’t run in days to weeks. I ohmed stator cold and it checked good. The ski would fire the plugs like twice then never again until the next start cycle. But if you let off the start button and tried again it would fire like two more times again. You couldn’t continue to hold the start button that would yield nothing, you had to stop then start and each initial crank the plugs would fire....but only like twice. I attempted several part swaps and attempts on a cold ski same result each time. So none of this was temp related. Is this the classic stator issue you mention you had?

A used igniter swap would not fix the issue, brand new coil did not fix the issue. I put in the MSD enhancer and it purred like a kitten.
 
Top Bottom